Tractography parameters for tckgen

Hello,
I started to work with the tractography on my DTI data. I have a multi shell DTI with 115 directions and 3 b0 (0, 1000, and 2000).
However, it is the first time that I use the tractography, and I have some doubts about the parameters that I have to use with tckgen.
I hope that someone can help me :slight_smile:
After the pre-processing, I resampled my data to 1.25 mm (originally, 2x2x2 mm)
After I used:
5ttgen on the T1-weighted images to generate the 5TT images
dwi2response with tournier
dwi2fod with csd
I created the white/grey matter border for seeds location
and I ran the tractography:

-algorithm iFOD2
-act 5TT
-backtrack
-nthreads 8
-minlength 15
-maxlength 250
-cutoff 0.06
n_seeds = 5 Milions

I am not sure if my parameters are totally correct. My big doubts are on -cutoff=0.06

Can someone that know better this part help me?

Thanks
Andrea

Hi Andrea,

After the pre-processing, I resampled my data to 1.25 mm (originally, 2x2x2 mm)

Firstly, it’s worth noting that this will change the default step size, which itself is based on voxel size. Is there a strong rationale behind this resampling? It’s used in the FBA pipeline for a specific purpose, which doesn’t necessarily translate to tractography; it can be beneficial for tractography as well, but it’s not something to just throw into a pipeline without knowledge of this consequence.

dwi2fod with csd

The dwi2fod csd algorithm will use only b=2000 data. Given you have multi-shell data, you can use the dwi2fod msmt_csd algorithm, which will make use of all of your DWI data, based on multi-shell response functions estimated using e.g. dwi2response dhollander.

My big doubts are on -cutoff=0.06

There is no correct answer to this question (or indeed any other here). I investigated cutoff a little when we revised the default parameters following software changes. The default in your circumstance is 0.05, so you could re-frame the question as “can I justify changing this parameter from the default?” (That way if it’s wrong you can blame me :expressionless: ) Same goes for minimum length: yours is considerably longer than the default in this case (2.5mm given your upsampling), and depending on what you’re doing this may or may not be consequential.

Cheers
Rob