Unable to open mrview

When I use mrtrix3 installed by anaconda, I will flash back when I input mrview on the terminal, and the following error occurs:

Dear @nana-zhang

I believe the the GUI of MRtrix does not work well on remote X connections: Building MRtrix3 from source — MRtrix 3.0 documentation

If you need to run MRtrix remotely, you might consider running it on the remote server, and then connect to it with RDP or VNC. Alternatively, you can try neurodesk. which lets you run MRtrix (and other neuroimaging software) remotely, and connect to the remote server using your web-browser. When you have neurodesk running, you can find MRtrix in the start menu under Neurodesk → Diffusion Imaging → mrtrix3 (check here for which MRtrix versions are available: Applications | NeuroDesk)

I’m contributing to both neurodesk and MRtrix, so you’re welcome to post here any questions you might have.


1 Like

Hi Oren, thanks for your suggestion about neurodesk. I also checked it out and the overview is really brilliant. I’m hoping containers would be a good improvement for my analysis.

However, i encountered some challenges during the installation (running the .exe file).

I already tried removing the image from docker, but not so sure how to go about this, i’m a bit new to using docker. Please can you provide a guide on how i can solve this error? Thanks.

Hi @Joanne

Thanks for the positive feedback on the Neurodesk documentation. We put a lot of effort to explain the utility of our tool, so I’m happy we could get the message through.

I’m consulting with my team about the .exe issue, and will get back to you shortly.
In the meantime, can you give more details on what you did up to now? (have you ran the .exe only once, or did you have to run it twice for some reason? what was the problem?)

More to come soon …

Thanks very much Oren for your prompt response. Yes i tried running it severally using both options (powershell and .exe), but i just tried running the .exe file again, and it seems to have worked! I got this display on my cmd and my browser automatically opened the neurodesk GUI.
i’ll send snapshots.

Please does it look like i’m on the right track?

Yes. Looks very good. Let me know if you have any issues or if you need a newer version of MRtrix included.
You’re also welcome to show it to your labmates, as we want as many people to benefit from it.

BTW, we are not sure what caused the problem you had earlier (specifically, we are not sure why the docker image didn’t finish downloading). If you can re-create the problem and tell me how you did it exactly, that would be appreciated.


Thanks a lot for the affirmation. Yes, i would definitely share it with them and i’m certain i would be back with more questions as i progress in my analysis using MRtrix and neurodesk.

Actually, i remember that i had to turn on “containers” from my windows features settings and then i waited for a while when the .exe file was running on the cmd prompt. During that time, the pop-up notification was similar to confirming if docker was connected and if i wanted to exit during a 10 seconds countdown. I just allowed this to run for a while and then it connected automatically. Sorry i didn’t take a snapshot then, i would have been able to explain better.

Thanks once again.