Unknown format for image in .nii format [Error]

Hi, I am trying to generate tracts using Tckgen, giving my inputs and the seeding image as:

tckgen wmfod.mif new_fiber.tck -algorithm iFOD2 -seed_image Left_seed.nii -select 7500 -seed_unidirectional -seed_direction 0,0,1 -stop -cutoff 0.07 -max_attempts_per_seed 1000

However, I am getting this error:

tckgen: [ERROR] unknown format for image “Left_seed.nii”
tckgen: [ERROR] error opening image “Left_seed.nii”

I tried to use mrinfo, but its giving the same error. Can you please suggest how I can proceed?

1 Like

Hi @Faizan,

First thing would be to figure out exactly where your Left_seed.nii image comes from, and if possible the exact command that was used to generate it. Next option is to use some other tool such as FSL’s fslhd to read the file, just to check whether MRtrix is having issues with an otherwise valid image, or if the problem is with the image itself.


Hi, Thanks a lot for the response. I got the seed images from our collaborators, so I don’t know yet where they came from, but I have been working with these images in 3D slicer, and it works perfectly fine. so, the image, I suppose, is valid.

Now, to get more accurate fiber tracts, I switched to MrTrix, but having this issue for now.
In theory, “.nii” should work. right?

Thanks in advance.

Ok, any chance you could send me the problematic image so I can go forensic on it?