Unusual Fibre Orientation Distribution estimation

Hi,
I wanted to visualize the fiber tracts so I followed the initial steps. First I made the response function estimation file and after checking that by shview it was fine. Then I made the FOD file, but the result showed me just some straight lines. I also made the tracts from that fod file which also as I expected was nothing like a tract at all. You can see the results in the images below.


I don’t know which part of my data has a problem.
Could you please help me in this regard?

Cheers,
Maryam

Hi Maryam, and welcome to the forum!

Yes, this doesn’t look right at all… This could be an issue with the DW direction set as acquired, or with a mismatch between the DW directions recorded in the header and what they actually were in reality. To get a handle on what’s going on, I’d suggest you post the output of:

dirstat dwi.mif

where dwi.mif is the raw input data, before you perform any processing – ideally you would pass the DICOM data directly here (e.g. you can replace dwi.mif with the name of the folder containing the DICOM images).

I would recommend you post all of the commands you used to process the data all the way up until the dwi2fod call. That may also give us a hint as to where the problem might have been introduced.

Hi jd,
Thanks for answering my question. I realized I am getting different results when I run the same data on different spaces. Because I do not have enough space on my laptop I have to use the external hard drive. For example, When I follow the initial steps to make the whole brain tractography image (image stored on my hard drive), in the 3rd step which is performing “Constrained Spherical Deconvolution (CSD)”, I get the wrong result, but when I transfer those images on my laptop and run the same commands, I get correct results.
The same problem sometimes happens with the “response function estimation” file as well.
The other problem is when I make the mask and check it, it is alright. But when I run the dwi2fod command, it says the mask is empty, then I check the mask and it is empty. It seems like it disappeared after running the second command. It is strange.

These are the commands I run:

dwi2mask dti.mif mask.mif

mrview dti.mif -roi.load mask.mif

dwi2response tournier dti.mif -mask mask.mif response.txt

shview response.txt

dwi2fod csd dti.mif response.txt fod.mif -mask mask.mif

I would appreciate it if you solve this mystery.

Thanks,
Maryam