Coregistration Failure

Dear MRtrix experts,

Hi! I’m a beginner in the field. I am trying to do a tractography on my data, where I ran into several problems. The data was already preprocessed via FSL.

I ran tckgen to do a probabilistic tractography, and got the following:

which clearly has many problems. (I’ve already tried the ‘dwigradcheck’) So we’ve done a quality check, and found a problematic result in the coregistration stage:

The prefrontal cortex is clearly not covered, and the boundary of the grey matter and the white matter doesn’t seem to be expressed correctly.
We are guessing that the coregistering parameters weren’t appropriate for our dataset - do you have any suggestions for changes we might be able to try?
Also we are suspecting that masking or segmentation may have gone wrong too, since the edge of the image is cut off so abruptly.

What may have gone wrong?
Thank you for your help in advance.


Does not look to bad to me. Could it be that you have used a high FA value in the last stage of tbss?

Thanks for the opinion! but unfortunately we didn’t do TBSS on our data…

I have gone through the exact same procedure on a different subject’s data, and found out that the problem wasn’t due to coregistration.

Even for the non-coregistered data (although not shown in the below screenshot), I got an image that has the PFC completely cut off:

so we are suspecting that segmentation, not coregistration, has gone wrong.
If it is so, could you give any advice about what we can fix and try again?

Thank you in advance!

You will have to provide much more detail about your pipeline. What kind of data are you using? What are the exact commands you ran to get to this result?

Outright cropping of a large portion of the brain like this can happen if running 5ttgen fsl on a T1-weighted image that has already been skull-stripped but the corresponding command-line option -premasked is not specified. FSL bet gets run on skull-stripped data, which in my experience tends to go awry; hence the presence of that command-line option.

I wouldn’t attribute your issues entirely to this though, the inter-modal alignment looks imperfect independently of the masking problem.

Yes, I do think it was due to running BET on the skull-stripped data at first,
so I went back using a non-skull stripped image.
Did go thru some other problems since my T1 image was in MP2RAGE format, but eventually solved those too! (for someone who might be experiencing a similar problem, check out 5ttgen fsl error - registration?)

Many thanks for everyone!