How Can I update My OpenGL

Dear MRtrix3 users,

I’m working on OpenGL (OpenGL version string: 1.4 (2.1 Mesa 20.1.0-devel (git-83f5a17a34))),
so when I run ‘mrview’ command line I’ve got this warning msg,

"X Error: GLXBadFBConfig 163
Extension: 149 (Uknown extension)
Minor opcode: 34 (Unknown request)
Resource id: 0x800039
mrview: [WARNING] unable to determine OpenGL version - operation may be unstable if actual version is less than 3.3
X Error: BadLength (poly request too large or internal Xlib length error) 16
Extension: 149 (Uknown extension)
Minor opcode: 2 (Unknown request)
Resource id: 0x800048
X Error: GLXBadLargeRequest 161
Extension: 149 (Uknown extension)
Minor opcode: 2 (Unknown request)
Resource id: 0x2 "

I tried to load the diffusion data, so I’ve got this error msg,

“mrview: [ERROR] error compiling OpenGL vertex shader ID 0
QWidget: Must construct a QApplication before a QPaintDevice
Aborted (core dumped)”
I though that I need to update my OpenGL version, So how can I update it?

I’m really stuck at this stage and need to move forward.
I will really appreciate any help from you.


Hi Abir,

This can indeed be tricky to get right… There’s a wiki article about it, but in short: the OpenGL version you can reasonably access on your system will depend on your specific hardware, the version of the drivers you’re running it with, and whether you’re accessing the system locally or remotely.

If you’re accessing the system remotely, it’s going to be very difficult to get to work – see this wiki post for details. Given it’s reporting OpenGL 1.4, I wouldn’t be surprised if this is a remote connection – mesa version 20 can normally provide OpenGL 4+ support even in software rendering mode…

If you’re running locally, then you need to figure out what your hardware is, and whether there are up to date OpenGL drivers for it that you can install. Running:


(potentially as super-user) will give you the details about your hardware. If it’s NVIDIA, ATI/AMD or Intel, you should definitely be able to run OpenGL 3.3 with the right drivers installed.

Dear Tournier,

The specifications of my system are:

Processor : Intel® Core™ i7-9700 CPU @ 3.00GHz
Installed RAM : 16.0 GB
System Type: 64-bit operating system, x64 based processor

I tried to update the version from OpenGL 1.4 to OpenGL 3.3, but didn’t work with me,
Really i need a quick fix; do you have any information?


I’m afraid there is no such thing… We’ll have to get to the bottom of it before you can proceed.

That doesn’t include the information related to your graphics card, which is what matters here (sorry, I should have been clearer on that point). Please post the full output of the following commands here, that’ll give us the required information:

lsb_release -a
uname -a