OpenGL display issues

OpenGL version 3.3 not supported

This will typically lead to mrview crashing with a message such as:

mrview: [ERROR] GLSL log [vertex shader]: ERROR: version '330' is not supported

There are three main reasons for this:

  1. Attempting to run MRView using X11 forwarding. This will not work without some effort; see the Wiki page on remote display for details.

  2. Your installation genuinely does not support OpenGL 3.3. In this case, the solution will involve figuring out:

    • Whether your graphics hardware can support OpenGL 3.3 at all;

    • Whether your Linux distribution provides any drivers for your graphics hardware that can support OpenGL 3.3;

    • If not, whether the manufacturer of your graphics hardware provides drivers for Linux that can be installed on your distribution;

    • How to install these drivers - a process that is invariably distribution-specific, and beyond the scope of this document. If you’re having serious issues with this, search around the rest of the community forum, and see if you can find a post from somebody else encountering the same issue. If no such post exists, you should consider creating a new topic on this forum. Make sure you provide as much information as you can (at the very least, your exact distribution, including which version of it, the exact model of your graphics hardware, and what you’ve tried so far). This Wiki page can then be updated with any identified solutions, which will then be easier for other users to locate.

  3. Your installation does support OpenGL 3.3, but only provides access to the 3.3 functionality through the compatibility profile, not through the (default) core profile. To see whether this is the problem, you only need to try setting the “NeedOpenGLCoreProfile” option in your MRtrix configuration file (typically ~/.mrtrix.conf):

    NeedOpenGLCoreProfile: 0

If this doesn’t work, you’re probably stuck with reason 2.

MRView runs with visual artefacts or no display

If you find that MRView displays with visual glitches or a blank screen, particularly in volume render mode, and on ATI/AMD hardware, you may find that setting the configuration file option NeedOpenGLCoreProfile to zero may resolve the problem:

    NeedOpenGLCoreProfile: 0